Official IS300 Cam/Head Thread - Page 6 - Lexus IS Forum
User Tag List

 3Likes
Reply
 
LinkBack Thread Tools
post #76 of 88 (permalink) Old 01-20-2015, 07:39 AM
Follower
 
Join Date: Jan 2012
Posts: 687
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
           
if you had other supporting mods, the tune would give you even more
lazyIS is offline  
Sponsored Links
Advertisement
 
post #77 of 88 (permalink) Old 01-20-2015, 09:28 AM
Aficionado
 
Join Date: Jun 2014
Location: South Suburbs of Chicago!
Posts: 877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 224 Post(s)
           
Quote:
Originally Posted by lazyIS View Post
if you had other supporting mods, the tune would give you even more
I've seen people get 10+ whp on just a tune, so a tune and cams should make for a very nice feeling car. Not fast, but more alive.
The Nuke is offline  
post #78 of 88 (permalink) Old 01-20-2015, 10:00 AM
Follower
 
Join Date: Jan 2012
Posts: 687
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
           
Quote:
Originally Posted by The Nuke View Post
I've seen people get 10+ whp on just a tune, so a tune and cams should make for a very nice feeling car. Not fast, but more alive.
I agree 100%. hence i'm waiting for headers before I get a tune too.

most people also get the cam gear, IMO it didn't do much, and if you are on automatic, you will get a CEL once in a while due to rough idle. its not an issue as it goes away after a few hundred miles, just a nuisance. after all that, the car is not fast, but does make it come alive, and as a DD it's great.
lazyIS is offline  
 
post #79 of 88 (permalink) Old 01-20-2015, 11:38 AM
Aficionado
 
Join Date: Jun 2014
Location: South Suburbs of Chicago!
Posts: 877
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 224 Post(s)
           
Quote:
Originally Posted by lazyIS View Post
I agree 100%. hence i'm waiting for headers before I get a tune too.

most people also get the cam gear, IMO it didn't do much, and if you are on automatic, you will get a CEL once in a while due to rough idle. its not an issue as it goes away after a few hundred miles, just a nuisance. after all that, the car is not fast, but does make it come alive, and as a DD it's great.
I will do cam gear as well, not for huge power gains by itself, but all the little things add up after awhile. Plus, I plan on doing some suspension/braking adds, so while it won't be fast it'll be a lot more fun to drive. :D
The Nuke is offline  
post #80 of 88 (permalink) Old 03-16-2015, 09:43 AM
Lurker
 
Join Date: Oct 2012
Location: Miami, Fl
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
           
Garage
Quote:
Originally Posted by franco305 View Post
Guys valves are getting super loud! Almost like a tickling noise. I tighted them to oem specs. Why nobody adjust the valves to what crower says?
Problem fixed, by reshimming them again. There were 2 shims that were a little loose on the intake side and we did not notice the first time (weird, maybe they move once they set in). I set clearance to the really tight side of oem specs and now at least the tickling noise is gone, but engine stills sounds like a train, a normal train though (compared to a customer's stock is300 it sounds the same).

A big plus to adjusting valves is that this time we used the toyota valve adjustment tool and an air compressor to literaly blow the shims away. The magnet stick does not work because it is too weak.

Thank you for the help guys
franco305 is offline  
post #81 of 88 (permalink) Old 04-20-2015, 11:14 PM
Loyalist
 
Join Date: Sep 2004
Location: Largo/Lutz, FL
Posts: 1,709
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
           
Quote:
Originally Posted by lazyIS View Post
most people also get the cam gear, IMO it didn't do much, and if you are on automatic, you awill get a CEL once in a while due to rough idle. its not an issue as it goes away after a few hundred miles, just a nuisance. after all that, the car is not fast, but does make it come alive, and as a DD it's great.
Q: So, e-shift/autos have a rough idle @ 1st after install? (& I'm assuming you're referring to the 264's)

'03 IS3: http://my.is/forums/f87/juicij36s-la...3/#post7846401
suspension:TeinSS/JICMagictower/CuscoAarm/CuscoTypeOS/Hotchkisanti/FIGStoe/FIGStraction/SRTsubframe/TRDlowerarm; engine/exhaust:BrianCrower264/HKSslidecam/SRTHFIw/AAFC/UnorthodoxRacingUltraSS/Dezodredhead/HKSCarbonTi; wheels/tires:WORKVS-XX/BridgestonePotenza; brakes:Rotora355X32; body:LSportline/TRD; lighting:AAC/Xetronic
juicij36 is offline  
post #82 of 88 (permalink) Old 04-21-2015, 07:20 AM
Lurker
 
Join Date: Mar 2015
Location: CA
Posts: 75
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
           
Quote:
Originally Posted by juicij36 View Post
Q: So, e-shift/autos have a rough idle @ 1st after install? (& I'm assuming you're referring to the 264's)
nothing of this sort happened with my auto after i put in the 264's. unplugged the battery before first startup and smooth sailing since. and no CEL.
10roller is offline  
post #83 of 88 (permalink) Old 07-13-2015, 06:40 AM Thread Starter
Guru
 
Bezik777's Avatar
 
Join Date: Mar 2009
Location: ILLinoiS
Posts: 9,729
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 36 Post(s)
           
Garage
Cams (264) shouldn't have ruff idle ..timing off or aftermarket cam gear (exhaust) adjusted wrong ,re check everything...
juicij36 likes this.

Support The Troops - OIF Veteran - SSG of Soldiers - AND PROUD OF IT

-Boosted-
-JCE10 Midwest-
___Go Fast or F*** It___
Bezik777 is offline  
post #84 of 88 (permalink) Old 07-13-2015, 07:58 AM
Loyalist
 
Join Date: Sep 2004
Location: Largo/Lutz, FL
Posts: 1,709
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
           
Good news.
Being installed now; I'll find out shortly.

'03 IS3: http://my.is/forums/f87/juicij36s-la...3/#post7846401
suspension:TeinSS/JICMagictower/CuscoAarm/CuscoTypeOS/Hotchkisanti/FIGStoe/FIGStraction/SRTsubframe/TRDlowerarm; engine/exhaust:BrianCrower264/HKSslidecam/SRTHFIw/AAFC/UnorthodoxRacingUltraSS/Dezodredhead/HKSCarbonTi; wheels/tires:WORKVS-XX/BridgestonePotenza; brakes:Rotora355X32; body:LSportline/TRD; lighting:AAC/Xetronic
juicij36 is offline  
post #85 of 88 (permalink) Old 12-15-2015, 01:47 PM
Newbie
 
Join Date: May 2015
Location: Albany OR
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
Good to know that there are cam options that will play nicely with OEM ecu and tune. Though I wonder how much of a difference you will see between a very basic cam with no changes VS an aggressive cam with a tune to compensate for differences. I guess the biggest deciding factor would be how much would it be to install a mild cam vs a moderate one plus tune divided by the price. Bang for Buck yo
Royale is offline  
post #86 of 88 (permalink) Old 01-10-2016, 02:55 PM
Lurker
 
Join Date: Oct 2013
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
 
Been driving with BC 264s for a year now, 15,000 miles later, still no CEL, solid AFRs everyday and such a blast to drive. My full BC head package is wonderful and brought new life to the car. By far the best mod i have done to my car in the over 3 years I have owned it. Do not even think twice about installing these cams. An intake and exhaust combo costs just as much and cannot beat the performance at all, get these and worry about supporting mods after!
juicij36 likes this.

2003 Mustang GT - Sonic Blue(sold)

2004 IS300 - GGP - 5 Speed Automatic - LSD
ACL - AEM - ARP - Brembo - BC - Eibach - Fidanza - Goodridge - NGK - Magnaflow - Megan - Mishimoto - Injen - PHR - Seibon - Spyder - Titan - Token Solutions - Tokico
Ciummo is offline  
post #87 of 88 (permalink) Old 10-22-2016, 04:39 PM
Newbie
 
Join Date: Oct 2016
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
 
I know this is old, but are there hotter spark plugs for us, and is so do they help in this car. I used Split-Fire in my old 85 Yota 4x4 w/31x11.50s, and 4.11 gears, and I did notice a difference. But, apples and oranges.
CanIHasFI is offline  
post #88 of 88 (permalink) Old 01-23-2017, 12:41 PM
Newbie
 
Join Date: Jul 2015
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
 
compression ratio for 264 cams and 1.3mm hg for turbo build

I posted my question in wrong thread possible here's link 2jz-ge, compression ratio w/cams just wondering ratios with set ups if known trying to calculate my build.
pfunkmixer is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > 1st-Gen IS300 > Go Fast Stuff

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome