Oil Maintenance Required Soon? - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 03-18-2008, 12:32 AM Thread Starter
Newbie
 
Join Date: Sep 2007
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Oil Maintenance Required Soon?

I'm not sure if this topic goes here, if not, please move. Ok I have a little problem here. I recently took my car into the Lexus dealer for their 5,000k mile comp. maintenance service. Well it hasn't been 1,000k miles yet and now when I turn on my car, it lights up "Oil Maintenance Required Soon." What is going on? Did they forget to reset the reminder or is my car really in need of another oil change? Thanks in advance.

2008 Lexus IS 250 - Tungsen Pearl
X-Package, 20% back, 35% front tint.
More upgrades to come..
BTRevolution is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-18-2008, 10:14 AM
Fiend
 
Join Date: Nov 2006
Location: Penna
Posts: 276
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Quote:
Originally Posted by BTRevolution View Post
I'm not sure if this topic goes here, if not, please move. Ok I have a little problem here. I recently took my car into the Lexus dealer for their 5,000k mile comp. maintenance service. Well it hasn't been 1,000k miles yet and now when I turn on my car, it lights up "Oil Maintenance Required Soon." What is going on? Did they forget to reset the reminder or is my car really in need of another oil change? Thanks in advance.
That warning comes on based on milage since the last reset, so they must have forgot to do that. I've seen postings how to reset it, but I forget precisely. You have to do something like hold in the odometer reset button while turning the ignition from off to on to start, or something like that. It should be in the manual.
bluehaha is offline  
post #3 of 15 (permalink) Old 03-18-2008, 10:23 AM
Immortal
 
Join Date: Jun 2002
Location: Florham Park, NJ 07932
Posts: 20,629
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Garage
1. Take the key out of ignition
2. Push in your trip reset button (hold it)
3. Put key in ignition and turn on but do not start the car
4. keep holding trip reset button for about 20 seconds, the light will come on steady and goes out.
5. You are done.

Master Certified Lexus VEHICLE TECHNOLOGY SPECIALIST @ LEXUS OF ROUTE 10
2012 UltraSonic Blue CT200h F-SPORT
2002 IBP JDM NEO/RANDO TURBO 500rwhp+@ 17 psi
R.I.P. 2001 SBM L-TUNED Toyomoto Built TURBO
LEXOTIC CONCEPTS NE017
ON ORDER: 2015 NX200t F-SPORT ULTRASONIC BLUE
tsopranoMB is offline  
post #4 of 15 (permalink) Old 03-21-2008, 10:50 AM
Altruist
 
Join Date: Sep 2005
Location: The Great State of Paranoia
Posts: 3,530
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Quote:
Originally Posted by tsopranoMB View Post
1. Take the key out of ignition
2. Push in your trip reset button (hold it)
3. Put key in ignition and turn on but do not start the car
4. keep holding trip reset button for about 20 seconds, the light will come on steady and goes out.
5. You are done.
^^^^
You do realize this is a 2nd Gen. We do not have keys to put in the ignition.


Here, try this:
To reset the oil change system, follow the procedure below:
1. Turn the engine switch OFF.
2. While pressing the trip meter reset knob (→P. 100), set the engine switch to the
IG-ON mode. Continue to press and hold the knob until the trip meter displays
000000.

SWTEA
Once I thought I was wrong.... but I was mistaken.


2008 IS250 BBM
2002 Tacoma DoubleCab IJM
2002 IS300 MSM(Sold) - Gone but not forgotten
Jekyl is offline  
post #5 of 15 (permalink) Old 03-28-2008, 08:06 PM
ddb
Lurker
 
Join Date: Feb 2008
Location: Miami, FL
Posts: 70
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
I believe that Jekyl instructions are correct. I haven’t tried myself yet as my car is brand new still (just passed 1000 miles mark). But I have reset other Toyota/Lexus and they are all about the same.

One note: it seems that when you reset the warning, it goes down by 1000 miles each second or so. This means that you need to hold down the trip for about 5 seconds so it completely resets. I never tried, but I think if you hold it for one second or two, you will extend the warning 1000 or 2000 miles. If this is correct, then maybe at the dealer the person who did the oil change, did the reset, but didn’t hold it long enough, maybe just did it for a second, so then after 1000 miles the warning came back on as expected.
Can anybody confirm this?
ddb is offline  
post #6 of 15 (permalink) Old 03-29-2008, 09:56 AM
Fiend
 
Join Date: Feb 2008
Location: Chicagoland
Posts: 459
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Yup, Jekyl's procedure is correct. Basically you will see a count down sequence like below from the odometer (ODO);

- - - - - -
- - - - -
- - - -
- - -
- -
-
000000

Also there are separate warnings that need to be reset if you have the Navigation system and those functions are enabled.

John
2007 IS250 AWD Black/Sterling, LUX, ML, NAV, AFS, PCS
NAVI-KIT R-Spec TTN-46, JoeZ Intake, Mazzuri Super Headers w/ceramic coating, Tanabe MT
http://www.youtube.com/watch?v=Dr9FokzQUHY
Gaugster is offline  
post #7 of 15 (permalink) Old 10-15-2008, 12:14 AM
Newbie
 
Join Date: Oct 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Thanks!

You guys are awesome. i actually work in the auto industry and i haven't been able to get someone to tell me how to reset this. Of course i have found that remembering to ask seems to be my biggest problem. i was the smart one who got talked into having my oil changed at the "required" six months and i only had 3k miles on my car - of course they didn't reset anything and since i hit 5k the light hasn't gone off. I'm trying it out tomorrow so everyone wish me luck.
KANDIET99 is offline  
post #8 of 15 (permalink) Old 10-15-2008, 12:18 PM
Fiend
 
Join Date: Feb 2008
Location: Chicagoland
Posts: 459
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Cool, welcome to the club. Enjoy the car.

John
2007 IS250 AWD Black/Sterling, LUX, ML, NAV, AFS, PCS
NAVI-KIT R-Spec TTN-46, JoeZ Intake, Mazzuri Super Headers w/ceramic coating, Tanabe MT
http://www.youtube.com/watch?v=Dr9FokzQUHY
Gaugster is offline  
post #9 of 15 (permalink) Old 05-08-2009, 02:04 PM
Newbie
 
Join Date: Mar 2009
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
I'm having the same issue, but still am not able to fix it with Jekyl's instructions...anyone got an idea on what's going on?
alpha_one is offline  
post #10 of 15 (permalink) Old 05-12-2009, 04:10 PM
Lurker
 
Join Date: Dec 2008
Location: Long Island
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Good looks Jekyl +rep, the instructions worked like a charm. I've been driving around with that on for a minute and it's annoying as hell. Thanks.

2008 IS 250
6 Speed Rwd
Obsidian Black on Black
Lexus Lip Kit
F-Sport Intake
18'x8 Konig Lace
Gloss black w/ mirror machine face.
clemente is offline  
post #11 of 15 (permalink) Old 05-12-2009, 04:22 PM
Geezer
 
bartkat's Avatar
 
Join Date: May 2003
Location: Heart of Dixie
Posts: 52,568
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Quote:
Originally Posted by alpha_one View Post
I'm having the same issue, but still am not able to fix it with Jekyl's instructions...anyone got an idea on what's going on?
Perhaps you're not doing it exactly right. It's also explained in the manual under "do it yourself maintenance".
bartkat is offline  
post #12 of 15 (permalink) Old 03-31-2010, 08:43 PM
Newbie
 
Join Date: Feb 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
i got the same problem and tried holding the damn thing for 60 secs, and no go. WTF, i'm about tohit the dealership. it's pissing me off!! but damn i do love that car.
vilenever is offline  
post #13 of 15 (permalink) Old 03-31-2010, 09:33 PM
Geezer
 
bartkat's Avatar
 
Join Date: May 2003
Location: Heart of Dixie
Posts: 52,568
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Read your manual. It's the same thing as has been posted here.
bartkat is offline  
post #14 of 15 (permalink) Old 02-21-2012, 08:53 AM
Newbie
 
Join Date: Sep 2006
Location: San Jose,CA
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
you have to hit the button 2x without touching the brake for it to work..once the3 red exclamation sign goes out for it to work..Thats what I had to do on my 08-IS350.
jamesalin is offline  
post #15 of 15 (permalink) Old 02-25-2012, 04:49 PM
Newbie
 
Join Date: Feb 2012
Location: Windsor
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
Awesome, I was trying to find this procedure in the manual but no luck. THanks
amw896 is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Owner's Forums > IS250 Owner's Forum

Quick Reply


Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome