check engine light, and clicking noise - Lexus IS Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 09-05-2005, 07:44 PM Thread Starter
Fiend
 
Join Date: Apr 2003
Location: Renton
Posts: 251
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
 
check engine light, and clicking noise

so heres the deal-

my car has been making this clicking noise for a while now. when im at idle its sounds fine, but when i accelerate from a complete stop, i hear a clicking in the begining of first gear, and it goes away after i hit 2nd, 3rd, and so on.. i hear it comming from my glove box, or in the intake part of the engine bay.i think it has something to do with intake or something.. agian its been like that for a while, and no proplems, no check engine light or anything..

but just a few days ago my check engine light just came up. i've noticed that the valvs sound a little bit louder lately, and my engine just doesn't sound like it usually does. does anyone know how to get the check engine codes? please, any advice would help. i plan on taking in to the dealer but its MAD expensive!! does anyone know a place that can diagnose my car for a more cheaper price?

also, my 90k maintenence service is comming up soon. that means timing blet time. does anyone know a place that does timing belts with quality but for less than the dealer? the quote i got was something like 2300 or something like that for the dealer.

thank you all in advance.

ps, sorry for the bad spelling. me gramar and spellin is not gud =p

-Jack

01 BO - PLP intake/ Jic Exhaust/ Apexi SFAC/ Tokiko 5 Way Adjustable Shocks/ Tien Springs/ Sports Design Grill/ Black Fogs/ Shaved Emblems/ 25% Tint

Romans 12:1-2
jb00gie is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-05-2005, 09:30 PM
Addict
 
maxxpsi's Avatar
 
Join Date: May 2003
Location: Heaven
Posts: 2,125
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
the clicking would be relays behind the glove box. Reset the ecu and see if the CEL comes back. Valves may need adjusting.
maxxpsi is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > Lexus IS > Basic Help & Repair

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome