cxracing turbo kit..........installed - Lexus IS Forum
User Tag List

 59Likes
Reply
 
LinkBack Thread Tools
post #1 of 250 (permalink) Old 07-22-2016, 11:02 AM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
cxracing turbo kit..........installed

so after back and forth with the 2 "budget" turbo kit company's there was a winner. got it and went over everything and it looked great. it took about 2 days, 5hrs at a time to install and go over. the oil drain line is a complete pain in the ass!!!! but once done everything else is cake honestly (dosn't hurt when my back yard is a 7 bay shop either ) but all in all it was a great buy. turbo works for now, but going to be replaced when I find suitable replacement. already swapped bov for an hks ssqv (my fav). exhaust and downpipe mated up no problems or clearance issues. only thing is there are only 2 bungs for the O2 sensors, will have to weld up a third. and an intercooler coupler didnt fit well so I used one I had lying around. left is to install sti 440 injectors, walbro pump, tune the aem fic and little crap like the turbo blanket and catch can. the kit is worth the money.
Attached Thumbnails
Click image for larger version

Name:	2.jpg
Views:	764
Size:	160.1 KB
ID:	99722   Click image for larger version

Name:	1.jpg
Views:	724
Size:	65.3 KB
ID:	99730   Click image for larger version

Name:	3.jpg
Views:	773
Size:	107.5 KB
ID:	99738   Click image for larger version

Name:	4.jpg
Views:	728
Size:	124.8 KB
ID:	99746  

Click image for larger version

Name:	6.jpg
Views:	830
Size:	136.9 KB
ID:	99762   Click image for larger version

Name:	7.jpg
Views:	741
Size:	106.7 KB
ID:	99770   Click image for larger version

Name:	8.jpg
Views:	740
Size:	84.4 KB
ID:	99778   Click image for larger version

Name:	9.jpg
Views:	731
Size:	122.4 KB
ID:	99786  

Click image for larger version

Name:	10.jpg
Views:	739
Size:	97.3 KB
ID:	99794  
c1L, jesuspuppy and MarcoBarone300 like this.

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
Sponsored Links
Advertisement
 
post #2 of 250 (permalink) Old 07-22-2016, 11:04 AM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
more pics
Attached Thumbnails
Click image for larger version

Name:	11.jpg
Views:	707
Size:	132.4 KB
ID:	99802   Click image for larger version

Name:	12.jpg
Views:	824
Size:	155.5 KB
ID:	99810   Click image for larger version

Name:	14.jpg
Views:	723
Size:	148.7 KB
ID:	99818   Click image for larger version

Name:	13.jpg
Views:	719
Size:	81.5 KB
ID:	99826  

MarcoBarone300 likes this.

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
post #3 of 250 (permalink) Old 07-22-2016, 11:05 AM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
I've put maybe 60 miles on it without tune and without beating on it. basically cruising around looking for leaks etc
Doesitcomeinblack_ likes this.

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
 
post #4 of 250 (permalink) Old 07-22-2016, 04:00 PM
Frequenter
 
Join Date: Nov 2015
Location: 305
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
 
Garage
looks bad ass man how does it feel compared to stock? video maybe? lol
Doesitcomeinblack_ is offline  
post #5 of 250 (permalink) Old 07-23-2016, 06:47 PM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
Quote:
Originally Posted by Doesitcomeinblack_ View Post
looks bad ass man how does it feel compared to stock? video maybe? lol
definitely feels peppier than stock thats for sure. semi tuned so its not as rich now. O2 sensors keep throwing codes so the factory ecu steps in over my fic every so often. but clear the light to run/tune it for now and it moves great! still havnt put injectors or walbro in yet, I want to get the O2 sensor thing ironed out first. as well as as I'm installing the kit I noticed a coolant leak developing where the head and block meet between cyl 3/4 so basically get things ironed out while getting ahold of a gte bottom end. Ill try to get video up and more pics. like I said all in all a great kit for the price!

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
post #6 of 250 (permalink) Old 07-23-2016, 07:04 PM
Frequenter
 
Join Date: Nov 2015
Location: 305
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
 
Garage
Quote:
Originally Posted by braintumor View Post
definitely feels peppier than stock thats for sure. semi tuned so its not as rich now. O2 sensors keep throwing codes so the factory ecu steps in over my fic every so often. but clear the light to run/tune it for now and it moves great! still havnt put injectors or walbro in yet, I want to get the O2 sensor thing ironed out first. as well as as I'm installing the kit I noticed a coolant leak developing where the head and block meet between cyl 3/4 so basically get things ironed out while getting ahold of a gte bottom end. Ill try to get video up and more pics. like I said all in all a great kit for the price!
awesome man, glad to hear the kit is quite worth the money, sorry to hear about your coolant leak, guess sounds like a head gasket.. i bought my car with a blown head gasket 5 months ago and today finally installed the valve body upgrade rods (auto) and bolted on the tranny to the engine, tomorrow ready to go back inside the car, i went with the XS power turbo kit tho, similar to the cx racing one.. build ge with GTE internals, its been quite a journey since doing everything alone .. and i will deff need help with the O2 sensors wiring so that the ecu thinks is fine too i have no idea how to do that ...

Last edited by Doesitcomeinblack_; 07-23-2016 at 07:11 PM.
Doesitcomeinblack_ is offline  
post #7 of 250 (permalink) Old 07-24-2016, 01:46 AM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
the O2 sensor thing is probably the biggest hurdle thus far. I've got the plug n play boomslang harness with the fic, so I need to figure out what and how to wire up both bank 1 sensors. So I'm honestly driving around with my small cornwell scanner plugged in and hitting the clear button when ever the light comes on.......it works so sue me lol. yeah when I got the car someone put a cheapo water pump in it and it blew as I was driving, overheating briefly. so I knew the head gasket would eventually be an issue, especially at 180k.
I also did the valve body rod upgrade before the turbo kit and it definitely shifts allot harder 2nd to 3rd and 3rd to 4th! tip: anyone doing it should pull the trans, flip it over and do the mod. I should have, would have made it sooooo much easier :/

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
post #8 of 250 (permalink) Old 07-24-2016, 09:59 AM
Frequenter
 
Join Date: Nov 2015
Location: 305
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
 
Garage
Quote:
Originally Posted by braintumor View Post
the O2 sensor thing is probably the biggest hurdle thus far. I've got the plug n play boomslang harness with the fic, so I need to figure out what and how to wire up both bank 1 sensors. So I'm honestly driving around with my small cornwell scanner plugged in and hitting the clear button when ever the light comes on.......it works so sue me lol. yeah when I got the car someone put a cheapo water pump in it and it blew as I was driving, overheating briefly. so I knew the head gasket would eventually be an issue, especially at 180k.
I also did the valve body rod upgrade before the turbo kit and it definitely shifts allot harder 2nd to 3rd and 3rd to 4th! tip: anyone doing it should pull the trans, flip it over and do the mod. I should have, would have made it sooooo much easier :/
lmao whatever works, what happens when the cel light comes on? the car starts acting up unless you clear it? yes this O2 sesnor mod has me shitting bricks i have no idea what to do on that.. and yes i had the engine and tranny out of the car it was super easy to do the valve body upgrade like this i honestly was expecting it to be more complicated but it was not
Doesitcomeinblack_ is offline  
post #9 of 250 (permalink) Old 07-24-2016, 01:21 PM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
when the light comes on the ecu thinks the O2s arn't working so it then thinks its running lean so it dumps gas into the engine. essentially un tuning the fic tune. so each one battles for control. I clear it and the fic takes back over control. I needed new O2s anyways, kept getting heater wire codes (from taking them in/out so often, might have worn the wires from twisting). I'd like O2 sims to make life easier but token dosnt offer the plug n plays anymore :/

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
post #10 of 250 (permalink) Old 07-24-2016, 07:49 PM
Enthusiast
 
Join Date: Oct 2010
Location: Hot Desert
Posts: 1,087
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 143 Post(s)
           
Quote:
Originally Posted by braintumor View Post
when the light comes on the ecu thinks the O2s arn't working so it then thinks its running lean so it dumps gas into the engine. essentially un tuning the fic tune. so each one battles for control. I clear it and the fic takes back over control. I needed new O2s anyways, kept getting heater wire codes (from taking them in/out so often, might have worn the wires from twisting). I'd like O2 sims to make life easier but token dosnt offer the plug n plays anymore :/
Try defoulers for your o2 sensors. Try disconnecting your o2 sensors from the connectors before you start twisting the wires up to get the sensors out of the bung. might save you money down the road
VEHEMENCE is offline  
post #11 of 250 (permalink) Old 07-25-2016, 12:34 AM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
the sensors arnt installed in the downpipe, its only got 2 bungs for sensors and there both way to for the factory length of the sensors. so I've got to extend the wires to even screw them in. I do unplug them as well, just with constant screwing them in and out the wires tend to still get caught or tangled on stuff (factory to header back to factory for emissions etc)

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
post #12 of 250 (permalink) Old 07-25-2016, 01:19 AM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
I can keep it at stoch at idle and at about 12 or so cruising
Attached Thumbnails
Click image for larger version

Name:	20160724_191251_resized.jpg
Views:	554
Size:	53.4 KB
ID:	100050  

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
post #13 of 250 (permalink) Old 07-26-2016, 01:24 AM
Frequenter
 
Join Date: Aug 2015
Location: Las Vegas, NV
Posts: 224
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
           
So they didn't factor this O2 Sensor issue into their design?
jesuspuppy is offline  
post #14 of 250 (permalink) Old 07-26-2016, 08:25 AM
Frequenter
 
Join Date: Nov 2015
Location: 305
Posts: 145
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
 
Garage
Quote:
Originally Posted by braintumor View Post
the sensors arnt installed in the downpipe, its only got 2 bungs for sensors and there both way to for the factory length of the sensors. so I've got to extend the wires to even screw them in. I do unplug them as well, just with constant screwing them in and out the wires tend to still get caught or tangled on stuff (factory to header back to factory for emissions etc)
so basically you are riding with none of the factory sensor installed on your down pipe, i inmagine you only have the wideband O2 sensor installed on the downpipe and other hole is plugged correct? this is why the light turns on eventually and you then have to clear it .. and it runs fine like this? sorry if im confused or sound confusing
Doesitcomeinblack_ is offline  
post #15 of 250 (permalink) Old 07-26-2016, 10:26 AM Thread Starter
Frequenter
 
Join Date: Apr 2015
Location: tempe,az
Posts: 185
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
   
Garage
yes exactly like that. there plugged in but hanging loose, so I eventually reset the light. I guess they didn't factor it in to the design, but its not a big deal. I will just weld in another bung or 2. the big deal was the oil drain line that needed to be factored in (I will say it again, giant pain in the ass!)

"alcohol, the cause of and solution to all of life's problems"
braintumor is online now  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > 1st-Gen IS300 > Go Faster

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Current users viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome