Aristo 2JZ-GTE VVTi Swap Doc - Page 7 - Lexus IS Forum
User Tag List

 2Likes
 
LinkBack Thread Tools
post #91 of 795 (permalink) Old 01-26-2008, 06:47 PM
Addict
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
Quote:
Originally Posted by IS_BoostByPsi View Post
Edit: did you guys keep the pressure tank or w/e on the intake side under the intake manifold? seems useless but i dont want to get rid of it if i keep twins.
Same question...I believe it can be removed with no ill CEL's but to the guys that have been there done that - Y or N ?

PS: Did you guys have a lot of oil residue within the twins piping and or comp sides themselves? Mine were rather oily with the first one almost having a puddle....but no shaft play and wheels spin freely...Not sure what to make of it.

Edit- GTE coilpack sitting and plugged in on the Aristo GTE. Will work much easier then on the GE head...
mikkellucci is offline  
Sponsored Links
Advertisement
 
post #92 of 795 (permalink) Old 01-27-2008, 02:55 PM
Altruist
 
IS_BoostByPsi's Avatar
 
Join Date: Jun 2005
Location: Cincy, Ohio
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
I had some oil residue, only on the intake side where the valve breather connects into the intake mani. I did have a little oil in the turbo pipes, but nothing to fret over. Let me know about those twins mike, I am not sure what to do about the iintake pipe.

I was thinking of gettin a stock supra flex pipe (the black one) that goes right onto the intake manifold and sing if I can manipulate it to where I want.

Second was to buy the Intercooler pipes from Samco, as their version seems to point it down at least in the direction we want.

o2' Black Onyx IS300 - Back to stock :( for now.
IS_BoostByPsi is offline  
post #93 of 795 (permalink) Old 01-28-2008, 10:35 AM
Addict
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
GTE Oil Pump

Did you guys buy a new GTE Oil Pump or take a chance with the Aristo one?
Also, what your thoughts on the prevelant issue(s) around the oem GTE oil pump, high boost and the front main seal failing? I recall a few threads on supraforums discussing the cause for concern even at 17psi:

The OEM oil pump is prone to front main seal failure under high boost conditions. We modify the oil pump to reduce pressure at the front main seal, increase internal flow, and balance and clearance the rotor assembly. All pumps are hand-modified and ported to ensure the highest quality.
mikkellucci is offline  
 
post #94 of 795 (permalink) Old 01-28-2008, 10:41 AM
Guru
 
TeCKis300's Avatar
 
Join Date: Aug 2001
Location: San Diego
Posts: 6,606
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
There's nothing inherently flawed in the Aristo (GTE) pump and should be good for many many miles to come.

Car sold to a good new home!

Full Aristo 2JZ-GTE BPU++ - Getrag v161 - EMU - Brembo BBK - CCW Classics 9F/10.5R - 255/35F - 285/30R - AAR Arms - GReddy Type-S - Hotchkis Sways - Teck Kit - Prolex / Cusco STB - Full ICE - HKS Drager - Prosport Prem Boost/EGT/FP - Innovative LC-1/XD-16 - Goodridge SS - TRD F/R Underbrace - Greddy Profec B Spec II - Megan Toe Arms
TeCKis300 is offline  
post #95 of 795 (permalink) Old 01-28-2008, 10:56 AM
Addict
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
Ok, I'll save $167.28. Thanks, Paul!
Another question if you can help me out: The Aristo Coolant Temp sensor vs GE: Does the GTE pickup/report temp differantly then the GE sensor or is this all a function in the ecu? I dont know what to do about my Haltech coolant temp sensor....what few Supra guys use Haltechs it was tough to form a concensus on coolant temp feedback for oem ecu and haltech. It would be far too easy if the GTE temp sensor could feed both the GE ecu and the Haltech.
mikkellucci is offline  
post #96 of 795 (permalink) Old 01-28-2008, 11:27 AM
Altruist
 
IS_BoostByPsi's Avatar
 
Join Date: Jun 2005
Location: Cincy, Ohio
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
I kept my oil pump. It looks perfectly fine. I am though replacing the front and rear main seals as I did see the posts on SF.

o2' Black Onyx IS300 - Back to stock :( for now.
IS_BoostByPsi is offline  
post #97 of 795 (permalink) Old 01-29-2008, 08:14 AM
Lurker
 
Join Date: Jan 2008
Location: Chicago, IL
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Great info. Keep it coming!

GT40R powered Mazda RX7 R1 FD3S
TheDecon is offline  
post #98 of 795 (permalink) Old 01-29-2008, 08:47 PM
Aficionado
 
Join Date: Oct 2007
Location: Iowa
Posts: 820
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Yes, excellent info! Can't wait to see it when its finished.
TurboIS_DJ is offline  
post #99 of 795 (permalink) Old 02-10-2008, 04:06 PM
Altruist
 
IS_BoostByPsi's Avatar
 
Join Date: Jun 2005
Location: Cincy, Ohio
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
Hey when replacing the water pump, you used an IS300 one right? cause they are hydrolic and supra's are clutch fan.

Cant I use a mkiv supra pump if I am not going to be pushing over 18 lbs of boost?

Where did you connect your fuel return lines on the rail?

o2' Black Onyx IS300 - Back to stock :( for now.
IS_BoostByPsi is offline  
post #100 of 795 (permalink) Old 02-10-2008, 04:30 PM
Guru
 
TeCKis300's Avatar
 
Join Date: Aug 2001
Location: San Diego
Posts: 6,606
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
You can't use the IS300 pump...it's configured differently. You need the Supra GTE water pump.

Car sold to a good new home!

Full Aristo 2JZ-GTE BPU++ - Getrag v161 - EMU - Brembo BBK - CCW Classics 9F/10.5R - 255/35F - 285/30R - AAR Arms - GReddy Type-S - Hotchkis Sways - Teck Kit - Prolex / Cusco STB - Full ICE - HKS Drager - Prosport Prem Boost/EGT/FP - Innovative LC-1/XD-16 - Goodridge SS - TRD F/R Underbrace - Greddy Profec B Spec II - Megan Toe Arms
TeCKis300 is offline  
post #101 of 795 (permalink) Old 02-10-2008, 05:30 PM
Addict
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
Yes, get the usdm GTE water pump.
For fuel return you have a few options where to tap into. Remove the hardline and do it at the reg., or use the end of the hardline OR end of the rubber line into hardline.

(Not my motor)

(Not my motor)

Last edited by mikkellucci; 02-11-2008 at 06:37 AM.
mikkellucci is offline  
post #102 of 795 (permalink) Old 02-10-2008, 10:30 PM
Altruist
 
IS_BoostByPsi's Avatar
 
Join Date: Jun 2005
Location: Cincy, Ohio
Posts: 3,830
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
           
wow mike, your intake runner have quite a bit of oil residue, nothing major its just noticeable.

o2' Black Onyx IS300 - Back to stock :( for now.
IS_BoostByPsi is offline  
post #103 of 795 (permalink) Old 02-11-2008, 06:43 AM
Addict
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
Zac, it pains me that you'd think that! Hell no, thats not my motor..its been sitting untouched since I pulled the twins, coilpacks/plugs and valvecovers.
mikkellucci is offline  
post #104 of 795 (permalink) Old 02-11-2008, 07:29 AM
Addict
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,460
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
           
While we're playing w/ pics - Can one of you swap vets (or anyone else) tell me what the busted lines in red are? Why are there what appear to be two small coolant lines coming off of a wider fitting or sensor? I believe these are ripped on my motor just as they appear in this pic:

mikkellucci is offline  
post #105 of 795 (permalink) Old 02-11-2008, 08:00 AM
Immortal
 
Join Date: Jun 2002
Location: Lake Worth, FL 33467
Posts: 20,658
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
           
Garage
^^ one goes to the reservoir...the other goes to the cooler....

Master Certified Lexus VEHICLE TECHNOLOGY SPECIALIST and INTERNET SALES MANAGER @ LEXUS OF PALM BEACH
2015 NX200t F-SPORT ULTRASONIC BLUE
1993 Toyota Supra
SOLD 2002 IBP JDM NEO/RANDO TURBO
500rwhp+@ 17 psi
R.I.P. 2001 SBM L-TUNED Toyomoto Built TURBO
LEXOTIC CONCEPTS NE017
tsopranoMB is offline  
Sponsored Links
Advertisement
 
Reply

  Lexus IS Forum > 1st-Gen IS300 > Go Faster

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Lexus IS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself. If your address is invalid, you will likely lose access to the site.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Current users viewing this Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome